Permissions needed? Font not showing.

Home Forums Use Any Fonts Permissions needed? Font not showing.

This topic contains 4 replies, has 2 voices, and was last updated by  Eric 1 year, 4 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #2965


    When I activated your plugin, it showed up in the page editor perfectly. I selected a font I uploaded to your plugin from the list.

    I saved the page
    I opened the page in draft. I see the font selected with ‘inspect element’ but it isn’t showing. I am guessing I need some permissions edited on my server to show the font? Can you tell me what needs to change as I am guessing my phone can’t find the font so it is reverting to the theme default.



    Hi Michael,

    Ya some server might block from loading the font. If that is the case there this should fix it. Please use this code in your htaccess file.

    Header set Access-Control-Allow-Origin “*”

    Hope this helps.




    Sorry, the code didn’t got published in previous reply.

    Here it is.

    <FilesMatch "\.(ttf|eot|woff)$">
    	<IfModule mod_headers.c>          
    		Header set Access-Control-Allow-Origin "*"  



    I am having similar problems with the font not showing on other computers.
    Where would I paste this code snippet in my htaccess?

    This is what it currently looks like:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /realmeal/
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /realmeal/index.php [L]

    # END WordPress





    I successfully uploaded a font to my website and assigned it to H1 & H2 headers. Font shows up in admin mode, but in regular viewing it reverts to another font in any browser (and not the primary default set in the theme settings).

    Is it possible that I have a similar .htaccess problem?


Viewing 5 posts - 1 through 5 (of 5 total)

The topic ‘Permissions needed? Font not showing.’ is closed to new replies.